Symptom
A backup fails with the error "There is not enough space on the disk".
Cause
This is seen when there is not enough space on the relevant drive to create a VSS snapshot in order to perform a backup.
Solution
Restarting the service will not solve the problem. You will need to ensure that the relevant drive has sufficient capacity before retrying. Below are some suggestions for freeing up capacity.
1. Old logs can take up unnecessary space. You can change the log file retention settings to retain less of the logs. To do this, open your ESE agent and go to Options > Logging. Enable Delete log files older than (days) if it is not enabled. If it is already enabled, set it to a lower number.
You can also delete your older logs at this point. Another way to free up space is to change the location where the logs are stored.
2. You can lower the retention of indexes to 7 days, which will clear up some space on the next backup. To do this, open your ESE agent and go to Options > Advanced > Working Folder. Select the option accessed within the last and ensure the number is set to 7. Click OK.
3. You can change the working folder to a drive that has more space. To do this, open your ESE agent and go to Options > Advanced > Working Folder, then click Change and select a new location.
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