Symptom
The initial presentation of this error is either
- a failure in starting the Redstor service, or
- a "Service not running" error message on opening a Data Management Agent.
Cause
For general use, the Agent will bind to three different local ports. The above error is encountered when the three ports the Agent had selected for use before are now being used by another service and are therefore unavailable when the Agent tries to bind to them. This is known as a JVM_Bind error.
To confirm that the JVM_Bind error is the cause of the problem, check the backupservice log file (default location C:\ProgramData\Redstor Pro\Backup Client ESE\logs\). You should see the following message there:
FATAL – Could not bind to socket using address 127.0.0.1 and port 50197
Java.net.BindException: Address already in use: JVM_Bind
Solution
To resolve the issue, you will need to force the Agent to bind to new local port numbers. To do this:
1. Open the Agent's a5backup.properties file (default location C:\Program Files\Redstor Pro\Backup Client ESE).
2. Locate the following lines:
service.rmi.port=51450
service.rpc-server.localhost.port=51449
service.port=51448
3. Remove the port numbers from these lines so that they read as follows:
service.rmi.port=
service.rpc-server.localhost.port=
service.port=
4. Save the a5backup.properties file.
5. Start the backup service.
If the service starts normally, the issue has been resolved and the Agent has been able to bind to three new local ports. You can now use the Agent as you normally would.
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