Symptom
When the TS Gateway system state writer (a part of the Remote Desktop Gateway) is included and there is no Files selection that includes the C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Administrative Tools\Remote Desktop Services folder, you may encounter the following error at backup time:
Missing entry at 'C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Administrative Tools\Remote Desktop Services\Remote Desktop Gateway Manager.lnk'
Cause
Windows Explorer has a feature that, given the correct settings in desktop.ini, will display a localised file or folder name instead of the actual file name. The TS Gateway VSS writer lists C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Administrative Tools\Remote Desktop Services\Remote Desktop Gateway Manager.lnk as a file to be included in the backup. In this case, Remote Desktop Gateway Manager.lnk is the localised name (as seen in Explorer), while the actual file name is RD Gateway Manager.lnk (as seen in PowerShell.) The writer is erroneously supplying the localised file name instead of the actual file name, resulting in the missing file error at backup time despite the file appearing to exist.
All files and folders shown in Redstor Pro are the actual file and folder names, not the localised names displayed by Explorer. Note that the parent folder Windows Administrative Tools is also a localised version of the actual folder name, which is Administrative Tools.
Solution
To get rid of the error and ensure that the correct files are backed up, manually include the C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Administrative Tools\Remote Desktop Services folder in the Files selection. The folder itself, or a parent folder, must be selected (not the RD Gateway Manager.lnk file) in order to prevent the error. Enabling Full System Backup will also cause the error to disappear, as it will select the entire C: drive.
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