Symptom
On attempting to use InstantData to recover Azure Virtual Machine files that have been backed up to Redstor's platform, certain files are not available for recovery.
Cause
This happens when Redstor Protect has been enabled in a configuration where it is not fully supported. For more information, see Article 1526 - Azure backup and recovery: frequently asked questions.
Workaround
Follow the steps below to recover the missing file/s:
1. Log into the RedApp and navigate to My Company > Azure > Virtual Machines.
2. Open the VM where the issue is occurring.
3. From the backups table, locate the desired backup date for which a snapshot is present. Expand its menu in the last column and go to Recover > New VM. You will now need to authenticate with Microsoft.
4. Provide the details for the recovery:
- Under Resource group, you will need to select a new resource group that you have created.
- Under VNET, select a network that is isolated from the original VM and accessible via RDP. Depending on the nature of the applications on the system, you may wish to block outbound connections from the target VNET.
- Enable Automatically power on VM after recovery.
5. Click Next at the bottom right to proceed.
6. Once the restore has completed, log into the restored VM via RDP.
7. Navigate to the desired file and copy it using a tool of your choice.
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