Symptom
The Enterprise Server Edition (ESE) Agent is unable to run a backup or start the service.
Cause
The ESE stores its local files separately in "C:\ProgramData\Attix5 Pro\Backup Client ESE". Only one path is specified. This data path can be changed in the ESE Agent GUI, but this may not always be possible. For example, if you run out of space on the C drive, the ESE Agent service will be unable to start, preventing you from changing the setting.
Solution
To fix the issue:
- Stop the ESE service.
- Navigate to the ESE installation folder (by default C:\Program Files\Attix5 Pro\Backup Client ESE\).
- Open the a5backup.properties file in Notepad.
- Find the line beginning odb.dir. If the line does not exist, create it and specify the new local data location, using double backslashes \\ for folder separators. For example, for the path F:\A5\Data the setting will be:
db.dr=F:\\A5\\Data
- Save and close the file.
- Move any existing data from the old data location to the new data location.
- When complete, start the ESE Service.
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