Symptom
The AccountServer database backup fails with the following error, as seen in the ASLog:
Warn: ASManager: Could not backup StoragePlatform database: Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding
Cause
This typically occurs on a AccountServer with a very large database. The backup of the large database takes longer than 60 seconds resulting in the connection between the AS and SQL timing out.
Solution
- Reduce the history of the TracePerformance table (this will not affect the Storage Platform).
- In Microsoft SQL Server Management Studio, edit the the Stored Procedure called TrimData.
In Object Explorer select, <SQLServer>\Databases\StoragePlatform\Programmability\Stored Procedures, then right-click on dbo.TrimData and select Modify. - Change:
Delete TracePerformance where LogDateTime < @date
to
Delete TracePerformance where LogDateTime < getdate() - 1This will ensure performance data older than 1 day is deleted.
- Select (highlight) this modified line and select Execute on the toolbar (or press F5).
- In Microsoft SQL Server Management Studio, edit the the Stored Procedure called TrimData.
- Compact the database
- Select New Query from the toolbar.
- Copy and paste the following into the new query:
DBCC SHRINKDATABASE(N'StoragePlatform' ) - Select Execute (or F5).
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