Symptom
The backup or restore logs will display an error message "GC overhead limit exceeded" when restoring or backing up using the ESE Agent:
WARN : 19:32:09 The 'C:\ProgramData\Microsoft\Crypto\RSA\S-1-5-18' folder has over '373,145' files. You should increase the memory allocation of the Backup service.
WARN : 19:34:27 Backup data response for C: terminated unexpectedly
INFO : 19:34:27 Backup waiting to shutdown
INFO : 19:34:27 Aborting VSS backup
INFO : 19:34:28 Deleting VSS snapshot set
ERROR : 19:34:28 Backup failed: GC overhead limit exceeded
Alternatively, the backup logs will show the following message:
ERROR : 19:34:28 Backup failed: Java heap space
In both cases, the backup-ui.log file will also contain the full stack trace showing "java.lang.OutOfMemoryError: Java heap space".
Cause
The number of folders selected in the Restore or Backup Selection tree is greater than what the Agent has memory to accommodate.
Solution
Increase the memory allocated to the Agent. To do this:
- Open the ESE Agent window and click the Options button.
- In the Options and Settings dialog box, select Advanced.
- Set the backup service amount to 1536 (the default is 512).
- Set the Agent interface to 1536 (the default is 1 024).
- Click OK.
- In order for the settings to take effect, the Agent window and service need to be restarted:
- Close the Agent window.
- Restart the "Redstor Backup Pro ESE" Windows service.
Changes will take effect when opening the Agent window again.
Note: Should the initial memory adjustment specified in Steps 3 and 4 not resolve the problem, it can be further increased up to 3072 MB.
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