Symptom
A backup fails with the following error:
Could not prepare for snapshot creation (VSS writer in an unexpected state):
writer timeout (0x800423f2); 'failed at freeze'
Cause
The error message "writer timeout (0x800423f2); 'failed at freeze'" is related to the Volume Shadow Copy Service (VSS) in Windows. This error typically indicates that there was an issue during the preparation of a snapshot for a backup or restore operation.
Solution
The first step in resolving this is to implement the VSS retry feature in the ESE agent. This will allow the agent to retry the backup process after a brief timeout, which could be helpful if disk activity is preventing the VSS snapshot. To implement the retry:
1. Stop the Redstor Pro ESE service.
2. Add the following to the a5backup.properties file (default location C:\Program Files\Redstor Pro\Backup Client ESE\):
contingency.backup.plan.enabled=true
3. Restart the ESE service.
You can also use the following steps to increase the timeout time for VSS operations:
1. Go to the Registry Editor by clicking on Start > Run and entering regedit.exe. Ensure that a backup of the registry is made before proceeding with any changes.
2. Locate the following registry entry:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\CurrentVersion\SPP\CreateTimeout
If the path above is not found, create it.
3. Right-click SPP and go to New > DWORD (32 bit) Value.
4. Enter the name: CreateTimeout.
5. In the Value data field, enter 2400000 (40 minutes). This sets a limit and not a goal.
6. For Windows Server 2012 or later, you will need to repeat the steps above for the following registry entry:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\VSS\Settings\IdleTimeout
A reboot is not required for these changes.
If the steps above do not help, please apply the following hotfix from Microsoft.
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