Symptom
The backup task for SIMS’s Discover component fails with the following error:
ERROR : 22:00:49 [Discover] Database 'servername\sims,DISCOVER' could not be saved for backup
Cause
Changes introduced to the Discover component of SIMS as part of the vendor's March 2023 software release cause the data collection process to fail, which in turn causes the backup to fail. Redstor has reported this problem to the vendor (ESS).
Software updates
Redstor will publish updates to the notice published on our Service Status board as they are received.
Please note that Redstor Support does not cover changes to third-party software. For enquiries regarding SIMS/FMS/Discover products, please contact your service provider or the software vendor (ESS) directly. For ease of reference, we have included their web page address: https://www.ess-sims.co.uk/
Workarounds
If you are experiencing this error, you may wish to consider one of the following actions:
1. Delay updating SIMS until this issue has been fixed by the vendor (This is believed to have been fixed in the Summer 2023 release).
2. Implement a temporary workaround so that the backup of Discover data can continue until a solution is provided by the vendor. You will need to ensure you are able to reconfigure the database to its working state (at the point of restore) after changing the way the database is backed up, and therefore a simulation test is strongly advised.
Two workaround options are suggested below.
- Workaround 1 – Backup from the SQL view in ESE
The ESE agent can backup Microsoft SQL Server databases using the Volume Shadow Copy Service (VSS). This feature can be used to collect the Discover database in SIMS. See Article 1119 - How to backup Microsoft SQL Server databases for the steps to set this up.
Note that the SQL restore process in ESE differs from the SIMS restore process. Read more in Article 1120 - How to restore Microsoft SQL Server databases.
- Workaround 2 – Manually change the contents of the config file
As an alternative, ESS (the SIMS vendor) suggests manually changing the contents of the config file, as shown here.
Remove the runtime block in the Discover.Backup.Console.exe.config file by changing the file contents from this:
to this:
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